caio.co/de/config.nvim


Remove diffview 💬 by Caio 2 months ago (log)
I rarely remember this is configured. Fugitive and meld are muscle
memory already

Blob lua/plugins.lua

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
return require('packer').startup(function()
    use 'wbthomason/packer.nvim'

    -- General-purpose editing plugins
    use {
        'tpope/vim-commentary',
        'tpope/vim-repeat',
        'tpope/vim-surround',
    }

    use {
        'tpope/vim-fugitive',
        cmd = 'Git',
    }

    use {
        'fatih/vim-go',
        -- ensure maximum regret when I open go files
        run = ':GoInstallBinaries',
        ft = {'go'},
        config = function()
            vim.g.go_gopls_enabled = 0
        end
    }

    use {
        'windwp/nvim-autopairs',
        event = 'InsertEnter',
        requires = { 'hrsh7th/nvim-cmp' },
        config = function()
            require('nvim-autopairs').setup({})

            local cmp_autopairs = require('nvim-autopairs.completion.cmp')
            local cmp = require('cmp')
            cmp.event:on('confirm_done', cmp_autopairs.on_confirm_done())
        end
    }

    -- Front-end stuff
    use {
        'yuezk/vim-js',
        'HerringtonDarkholme/yats.vim',
        'maxmellon/vim-jsx-pretty',
    }

    use { 'qpkorr/vim-renamer', cmd = 'Renamer' }

    use {
        'mcchrish/zenbones.nvim',
        requires = { 'rktjmp/lush.nvim' },
        config = function()
            vim.g.zenbones_darkness = "stark" -- warm/undef
            vim.g.zenbones_lightness = "bright" -- dim/undef
            vim.opt.termguicolors = true
            vim.opt.background = "dark"
            vim.cmd("colorscheme zenbones")
        end
    }

    -- autocomplete
    use {
        'hrsh7th/nvim-cmp',
        requires = {
            {'hrsh7th/cmp-nvim-lsp'},
            {'hrsh7th/cmp-buffer'},
        },
        config = function()
            require('config.completions')
        end
    }

    use {
        'nvim-telescope/telescope.nvim',
        requires = {{'nvim-lua/plenary.nvim'}},
        config = function()
            require('config.telescope')
        end
    }

    -- Only gets loaded when `:LspStart` is called manually
    use {
        'neovim/nvim-lspconfig',
        cmd = 'LspStart',
        config = function()
            require('config.lsp')
        end
    }

    use {
        'nvim-treesitter/nvim-treesitter',
        run = ':TSUpdate',
        config = function()
            require('config.treesitter')
        end
    }
end)